plesk command line

Please use mysql_upgrade to fix this error - Plesk fix

Submitted by gazza on Thu, 24/09/2020 - 10:31

This error occurred in my environment when I tried to create a database dump. This happened after I updated the MariaDB from version 10.2.x to 10.3.x. After upgrading your MySQL you have to run  mysql_upgrade to fix any incompatibilities in System tables. 

Just run the below command at your Plesk command line after upgrading your MySQL, restart MySQL and it will fix the issue:

Upgrade MySQL databases:

MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql_upgrade -uadmin

Restart the MySQP service

systemctl restart mysql

How to update Drupal core and it's dependencies using composer

Submitted by gazza on Sat, 18/07/2020 - 13:59

Below is the command line code that you can copy and paste into your favorite command line terminal.

composer update drupal/* --with-dependencies

If you are using Plesk, you can access composer globally byusing the following command. Obviously change the php version to the one you are using.

/opt/plesk/php/7.4/bin/php /usr/lib64/plesk-9.0/composer.phar update drupal/* --with-dependencies